Xterra Random Start problem

Having problems with your Nissan truck? Search & post here!

Xterra Random Start problem

Postby ARCTICboy » Sat Feb 23, 2019 6:43 pm

Hello....

Just wondering if anyone can help me out. I have a intermittent starting problem on my 2002 Xterra SC.

- Starter has been replaced 5 months ago
- Plugs, plug wire, cap and rotor replace 8 months ago
- Fuel pump and fuel filter replaced 1 year ago
- Battery replaced 1year ago
- MAF replaced 5 years ago and is clean.

No check engine light and only code was a Knock sensor code.

It doesn't seem to be a heat or cold issue, has started in -30 and +5 so far this winter.

When it does refuse to start it turns over fine but never seems to catch, almost like a fuel starvation issue. It has only once died on my while driving, no jerking or any preliminary signs just total shut off from the motor. 20 minutes later it restarted and was fine.

Could it be a sensor or possibly the Distributor?

Thank you for reading this :)

Marcus
ARCTICboy
Newbie
 
Posts: 16
Make/Model: Xterra
Year: 2002

Re: Xterra Random Start problem

Postby Adam » Mon Feb 25, 2019 12:10 am

Sounds like a classic distributor issue. To confirm you can take the cap off and look for any red/brown/gold coloured dust or flakes. It usually runs fine when cold but acts up when warm. What's the mileage on it?

FYI watch out for the primary cat converters breaking down and getting sucked into the motor. I killed my first engine that way.
2002 Xterra SE/SC - 5 Speed manual.
1994 Pathfinder SE-V6 - Auto (re4r01a-hd swap) 6" lift, ARB bar, 33x10.5 KM2, Blackpanther skid plates, oil filter relocation, lots of dents and rust.
User avatar
Adam
Premium Member
Premium Member
 
Posts: 2665
Make/Model: Pathfinder SE-V6
Year: 1994
Tim's: Medium 1C1S

Re: Xterra Random Start problem

Postby ARCTICboy » Mon Feb 25, 2019 12:19 pm

Hi Adam.

Thank you for the reply.

It has 281,oooKm. It doesn't seem to be temp issue. It sometimes will not start when cold or hot. Mostly cold I would say.
ARCTICboy
Newbie
 
Posts: 16
Make/Model: Xterra
Year: 2002

Re: Xterra Random Start problem

Postby Adam » Mon Feb 25, 2019 2:18 pm

I'd still take the distributor cap off and check for dust/flakes. If there is any then the bearing has failed.
2002 Xterra SE/SC - 5 Speed manual.
1994 Pathfinder SE-V6 - Auto (re4r01a-hd swap) 6" lift, ARB bar, 33x10.5 KM2, Blackpanther skid plates, oil filter relocation, lots of dents and rust.
User avatar
Adam
Premium Member
Premium Member
 
Posts: 2665
Make/Model: Pathfinder SE-V6
Year: 1994
Tim's: Medium 1C1S

Re: Xterra Random Start problem

Postby ARCTICboy » Mon Feb 25, 2019 10:24 pm

Cool. Going to have a look at it tomorrow. Thanks for the help.
ARCTICboy
Newbie
 
Posts: 16
Make/Model: Xterra
Year: 2002

Re: Xterra Random Start problem

Postby Adam » Wed Feb 27, 2019 12:19 pm

Let us know what you find.
2002 Xterra SE/SC - 5 Speed manual.
1994 Pathfinder SE-V6 - Auto (re4r01a-hd swap) 6" lift, ARB bar, 33x10.5 KM2, Blackpanther skid plates, oil filter relocation, lots of dents and rust.
User avatar
Adam
Premium Member
Premium Member
 
Posts: 2665
Make/Model: Pathfinder SE-V6
Year: 1994
Tim's: Medium 1C1S

Re: Xterra Random Start problem

Postby ARCTICboy » Thu Mar 07, 2019 1:43 pm

All is good under the cap.

Could it be a knock sensor telling the computer to not send fuel?
ARCTICboy
Newbie
 
Posts: 16
Make/Model: Xterra
Year: 2002

Re: Xterra Random Start problem

Postby Adam » Sat Mar 16, 2019 9:58 pm

The knock sensor just robs you of your power/boost when it is bad. 99% of the no start problems on these trucks are caused by the damn distributor lol.
2002 Xterra SE/SC - 5 Speed manual.
1994 Pathfinder SE-V6 - Auto (re4r01a-hd swap) 6" lift, ARB bar, 33x10.5 KM2, Blackpanther skid plates, oil filter relocation, lots of dents and rust.
User avatar
Adam
Premium Member
Premium Member
 
Posts: 2665
Make/Model: Pathfinder SE-V6
Year: 1994
Tim's: Medium 1C1S


Return to Problems & Fixes

Who is online

Users browsing this forum: No registered users and 3 guests

cron